Dell Precision and docking issues (E-Dock / WD15 / TB16)

I’ve been using my Dell Precision 7520 for quite a while now and have used it in combination with three different docking stations.

E-dock

The Precision series are still equipped with E-dock connection, which I thought was a major benefit, so there was no need upgrading to USB-C dock instantly.

I have used an E-dock for several months (with 1 Dell 1920*1200 monitor). Resulting in several Windows 10 crashes. Always had to shut down the device and (re)boot it. Coming out of sleep also resulted in crashes quite randomly. Had my motherboard replaced by Dell, changed hard drives, … no effect.

WD15

Then I started using a Dell WD15 dock (with 2 Dell 1920*1200 monitors) and I haven’t had any problems whatsoever. When connecting the USB-C cable, the laptop awakes from sleep with no problems. Sometimes external screens go dark for 2 seconds and light up again. But this hiccup only happens once in a while and you can continue work without further problems.

TB16

For a few weeks I had the opportunity to test the Dell Thunderbolt TB16 on my device (with 2 Dell 1920*1200 monitors) and the same problems as mentioned with the E-Dock emerged. Random crashes and not being able to connect to external monitors upon connecting the USB-C cable, resulting in a crash. Crash also occured when launching Photoshop. I  think it also boils down to a graphics problem?

Conclusion

So now I’m using the Dell WD15 again. Aside from a more limited graphic ability (amount / resolution of external monitors), the only downside is that power over USB (docking ports) only seem to work when the connected laptop is active.

Your thoughts?

Anyone having the same issues? Firmware upgrading never did the trick and advanced diagnostics never showed any problems.